<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html dir='ltr' xmlns='http://www.w3.org/1999/xhtml' xmlns:b='http://www.google.com/2005/gml/b' xmlns:data='http://www.google.com/2005/gml/data' xmlns:expr='http://www.google.com/2005/gml/expr'>
<head>
<link href='https://www.blogger.com/static/v1/widgets/3957297643-widget_css_bundle.css' rel='stylesheet' type='text/css'/>
<meta content='width=device-width, initial-scale=1.0' name='viewport'/>
<link href='http://fonts.googleapis.com/css?family=Oswald' rel='stylesheet' type='text/css'/>
<meta content='text/html; charset=UTF-8' http-equiv='Content-Type'/>
<meta content='blogger' name='generator'/>
<link href='http://www.punchdrunkcritics.com/favicon.ico' rel='icon' type='image/x-icon'/>
<link href='http://www.punchdrunkcritics.com/2018/04/rogue-one-star-donnie-yen-cast-in.html' rel='canonical'/>
<link rel="alternate" type="application/atom+xml" title="Punch Drunk Critics - Atom" href="http://www.punchdrunkcritics.com/feeds/posts/default" />
<link rel="alternate" type="application/rss+xml" title="Punch Drunk Critics - RSS" href="http://www.punchdrunkcritics.com/feeds/posts/default?alt=rss" />
<link rel="service.post" type="application/atom+xml" title="Punch Drunk Critics - Atom" href="https://www.blogger.com/feeds/2830313173919008722/posts/default" />

<link rel="alternate" type="application/atom+xml" title="Punch Drunk Critics - Atom" href="http://www.punchdrunkcritics.com/feeds/6688079757121638420/comments/default" />
<!--Can't find substitution for tag [blog.ieCssRetrofitLinks]-->
<link href='https://1.bp.blogspot.com/-yMA4IOgiIEs/Ws7rRc--MVI/AAAAAAACM0Q/HE1tHRh_CAYEaz0HUZt4hta3zeulpmdmwCLcBGAs/s400/Rogue-One-Star-Wars-Story-Chirrut-Imwe-Blind.jpg' rel='image_src'/>
<meta content='http://www.punchdrunkcritics.com/2018/04/rogue-one-star-donnie-yen-cast-in.html' property='og:url'/>
<meta content='&#39;Rogue One&#39; Star Donnie Yen Cast In Disney&#39;s Live-Action &#39;Mulan&#39; ' property='og:title'/>
<meta content='   This seems like such a no-brainer it&#39;s a wonder to have taken so long. The incredible Donnie Yen has joined the cast of Disney&#39;s live-act...' property='og:description'/>
<meta content='https://1.bp.blogspot.com/-yMA4IOgiIEs/Ws7rRc--MVI/AAAAAAACM0Q/HE1tHRh_CAYEaz0HUZt4hta3zeulpmdmwCLcBGAs/w1200-h630-p-k-no-nu/Rogue-One-Star-Wars-Story-Chirrut-Imwe-Blind.jpg' property='og:image'/>
<!--[if IE]> <script> (function() { var html5 = ("abbr,article,aside,audio,canvas,datalist,details," + "figure,footer,header,hgroup,mark,menu,meter,nav,output," + "progress,section,time,video").split(','); for (var i = 0; i < html5.length; i++) { document.createElement(html5[i]); } try { document.execCommand('BackgroundImageCache', false, true); } catch(e) {} })(); </script> <![endif]-->
<!-- Start www.bloggertipandtrick.net: Changing the Blogger Title Tag -->
<title>'Rogue One' Star Donnie Yen Cast In Disney's Live-Action 'Mulan'  ~ Punch Drunk Critics</title>
<!-- End www.bloggertipandtrick.net: Changing the Blogger Title Tag -->
<style id='page-skin-1' type='text/css'>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</style>
<meta content='dmlgun9ajzd0fnvu5' name='dailymotion-domain-verification'/>
<script src='https://ajax.googleapis.com/ajax/libs/jquery/1.11.1/jquery.min.js' type='text/javascript'></script>
<script type='text/javascript'>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</script>
<script type='text/javascript'>
//<![CDATA[

/**
 * jQuery Mobile Menu 
 * Turn unordered list menu into dropdown select menu
 * version 1.0(31-OCT-2011)
 * 
 * Built on top of the jQuery library
 *   http://jquery.com
 * 
 * Documentation
 * 	 http://github.com/mambows/mobilemenu
 */
(function($){
$.fn.mobileMenu = function(options) {
	
	var defaults = {
			defaultText: 'Navigate to...',
			className: 'select-menu',
			containerClass: 'select-menu-container',
			subMenuClass: 'sub-menu',
			subMenuDash: '&ndash;'
		},
		settings = $.extend( defaults, options ),
		el = $(this);
	
	this.each(function(){
		// ad class to submenu list
		el.find('ul').addClass(settings.subMenuClass);

        // Create base menu
		$('<div />',{
			'class' : settings.containerClass
		}).insertAfter( el );
        
		// Create base menu
		$('<select />',{
			'class' : settings.className
		}).appendTo( '.' + settings.containerClass );

		// Create default option
		$('<option />', {
			"value"		: '#',
			"text"		: settings.defaultText
		}).appendTo( '.' + settings.className );

		// Create select option from menu
		el.find('a').each(function(){
			var $this 	= $(this),
					optText	= '&nbsp;' + $this.text(),
					optSub	= $this.parents( '.' + settings.subMenuClass ),
					len			= optSub.length,
					dash;
			
			// if menu has sub menu
			if( $this.parents('ul').hasClass( settings.subMenuClass ) ) {
				dash = Array( len+1 ).join( settings.subMenuDash );
				optText = dash + optText;
			}

			// Now build menu and append it
			$('<option />', {
				"value"	: this.href,
				"html"	: optText,
				"selected" : (this.href == window.location.href)
			}).appendTo( '.' + settings.className );

		}); // End el.find('a').each

		// Change event on select element
		$('.' + settings.className).change(function(){
			var locations = $(this).val();
			if( locations !== '#' ) {
				window.location.href = $(this).val();
			};
		});

	}); // End this.each

	return this;

};
})(jQuery);

//]]>
</script>
<script type='text/javascript'>
//<![CDATA[

(function($){
	/* hoverIntent by Brian Cherne */
	$.fn.hoverIntent = function(f,g) {
		// default configuration options
		var cfg = {
			sensitivity: 7,
			interval: 100,
			timeout: 0
		};
		// override configuration options with user supplied object
		cfg = $.extend(cfg, g ? { over: f, out: g } : f );

		// instantiate variables
		// cX, cY = current X and Y position of mouse, updated by mousemove event
		// pX, pY = previous X and Y position of mouse, set by mouseover and polling interval
		var cX, cY, pX, pY;

		// A private function for getting mouse position
		var track = function(ev) {
			cX = ev.pageX;
			cY = ev.pageY;
		};

		// A private function for comparing current and previous mouse position
		var compare = function(ev,ob) {
			ob.hoverIntent_t = clearTimeout(ob.hoverIntent_t);
			// compare mouse positions to see if they've crossed the threshold
			if ( ( Math.abs(pX-cX) + Math.abs(pY-cY) ) < cfg.sensitivity ) {
				$(ob).unbind("mousemove",track);
				// set hoverIntent state to true (so mouseOut can be called)
				ob.hoverIntent_s = 1;
				return cfg.over.apply(ob,[ev]);
			} else {
				// set previous coordinates for next time
				pX = cX; pY = cY;
				// use self-calling timeout, guarantees intervals are spaced out properly (avoids JavaScript timer bugs)
				ob.hoverIntent_t = setTimeout( function(){compare(ev, ob);} , cfg.interval );
			}
		};

		// A private function for delaying the mouseOut function
		var delay = function(ev,ob) {
			ob.hoverIntent_t = clearTimeout(ob.hoverIntent_t);
			ob.hoverIntent_s = 0;
			return cfg.out.apply(ob,[ev]);
		};

		// A private function for handling mouse 'hovering'
		var handleHover = function(e) {
			// next three lines copied from jQuery.hover, ignore children onMouseOver/onMouseOut
			var p = (e.type == "mouseover" ? e.fromElement : e.toElement) || e.relatedTarget;
			while ( p && p != this ) { try { p = p.parentNode; } catch(e) { p = this; } }
			if ( p == this ) { return false; }

			// copy objects to be passed into t (required for event object to be passed in IE)
			var ev = jQuery.extend({},e);
			var ob = this;

			// cancel hoverIntent timer if it exists
			if (ob.hoverIntent_t) { ob.hoverIntent_t = clearTimeout(ob.hoverIntent_t); }

			// else e.type == "onmouseover"
			if (e.type == "mouseover") {
				// set "previous" X and Y position based on initial entry point
				pX = ev.pageX; pY = ev.pageY;
				// update "current" X and Y position based on mousemove
				$(ob).bind("mousemove",track);
				// start polling interval (self-calling timeout) to compare mouse coordinates over time
				if (ob.hoverIntent_s != 1) { ob.hoverIntent_t = setTimeout( function(){compare(ev,ob);} , cfg.interval );}

			// else e.type == "onmouseout"
			} else {
				// unbind expensive mousemove event
				$(ob).unbind("mousemove",track);
				// if hoverIntent state is true, then call the mouseOut function after the specified delay
				if (ob.hoverIntent_s == 1) { ob.hoverIntent_t = setTimeout( function(){delay(ev,ob);} , cfg.timeout );}
			}
		};

		// bind the function to the two event listeners
		return this.mouseover(handleHover).mouseout(handleHover);
	};
	
})(jQuery);

//]]>
</script>
<script type='text/javascript'>
//<![CDATA[

/*
 * Superfish v1.4.8 - jQuery menu widget
 * Copyright (c) 2008 Joel Birch
 *
 * Dual licensed under the MIT and GPL licenses:
 * 	http://www.opensource.org/licenses/mit-license.php
 * 	http://www.gnu.org/licenses/gpl.html
 *
 * CHANGELOG: http://users.tpg.com.au/j_birch/plugins/superfish/changelog.txt
 */

;(function($){
	$.fn.superfish = function(op){

		var sf = $.fn.superfish,
			c = sf.c,
			$arrow = $(['<span class="',c.arrowClass,'"> &#187;</span>'].join('')),
			over = function(){
				var $$ = $(this), menu = getMenu($$);
				clearTimeout(menu.sfTimer);
				$$.showSuperfishUl().siblings().hideSuperfishUl();
			},
			out = function(){
				var $$ = $(this), menu = getMenu($$), o = sf.op;
				clearTimeout(menu.sfTimer);
				menu.sfTimer=setTimeout(function(){
					o.retainPath=($.inArray($$[0],o.$path)>-1);
					$$.hideSuperfishUl();
					if (o.$path.length && $$.parents(['li.',o.hoverClass].join('')).length<1){over.call(o.$path);}
				},o.delay);	
			},
			getMenu = function($menu){
				var menu = $menu.parents(['ul.',c.menuClass,':first'].join(''))[0];
				sf.op = sf.o[menu.serial];
				return menu;
			},
			addArrow = function($a){ $a.addClass(c.anchorClass).append($arrow.clone()); };
			
		return this.each(function() {
			var s = this.serial = sf.o.length;
			var o = $.extend({},sf.defaults,op);
			o.$path = $('li.'+o.pathClass,this).slice(0,o.pathLevels).each(function(){
				$(this).addClass([o.hoverClass,c.bcClass].join(' '))
					.filter('li:has(ul)').removeClass(o.pathClass);
			});
			sf.o[s] = sf.op = o;
			
			$('li:has(ul)',this)[($.fn.hoverIntent && !o.disableHI) ? 'hoverIntent' : 'hover'](over,out).each(function() {
				if (o.autoArrows) addArrow( $('>a:first-child',this) );
			})
			.not('.'+c.bcClass)
				.hideSuperfishUl();
			
			var $a = $('a',this);
			$a.each(function(i){
				var $li = $a.eq(i).parents('li');
				$a.eq(i).focus(function(){over.call($li);}).blur(function(){out.call($li);});
			});
			o.onInit.call(this);
			
		}).each(function() {
			var menuClasses = [c.menuClass];
			if (sf.op.dropShadows  && !($.browser.msie && $.browser.version < 7)) menuClasses.push(c.shadowClass);
			$(this).addClass(menuClasses.join(' '));
		});
	};

	var sf = $.fn.superfish;
	sf.o = [];
	sf.op = {};
	sf.IE7fix = function(){
		var o = sf.op;
		if ($.browser.msie && $.browser.version > 6 && o.dropShadows && o.animation.opacity!=undefined)
			this.toggleClass(sf.c.shadowClass+'-off');
		};
	sf.c = {
		bcClass     : 'sf-breadcrumb',
		menuClass   : 'sf-js-enabled',
		anchorClass : 'sf-with-ul',
		arrowClass  : 'sf-sub-indicator',
		shadowClass : 'sf-shadow'
	};
	sf.defaults = {
		hoverClass	: 'sfHover',
		pathClass	: 'overideThisToUse',
		pathLevels	: 1,
		delay		: 800,
		animation	: {opacity:'show'},
		speed		: 'normal',
		autoArrows	: true,
		dropShadows : true,
		disableHI	: false,		// true disables hoverIntent detection
		onInit		: function(){}, // callback functions
		onBeforeShow: function(){},
		onShow		: function(){},
		onHide		: function(){}
	};
	$.fn.extend({
		hideSuperfishUl : function(){
			var o = sf.op,
				not = (o.retainPath===true) ? o.$path : '';
			o.retainPath = false;
			var $ul = $(['li.',o.hoverClass].join(''),this).add(this).not(not).removeClass(o.hoverClass)
					.find('>ul').hide().css('visibility','hidden');
			o.onHide.call($ul);
			return this;
		},
		showSuperfishUl : function(){
			var o = sf.op,
				sh = sf.c.shadowClass+'-off',
				$ul = this.addClass(o.hoverClass)
					.find('>ul:hidden').css('visibility','visible');
			sf.IE7fix.call($ul);
			o.onBeforeShow.call($ul);
			$ul.animate(o.animation,o.speed,function(){ sf.IE7fix.call($ul); o.onShow.call($ul); });
			return this;
		}
	});

})(jQuery);



//]]>
</script>
<script type='text/javascript'>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</script>
<script type='text/javascript'>
/* <![CDATA[ */
jQuery.noConflict();		
jQuery(function () {
    jQuery('ul.menu-primary').superfish({
        animation: {
            opacity: 'show'
        },
        autoArrows: true,
        dropShadows: false,
        speed: 200,
        delay: 800
    });
});

jQuery(document).ready(function() {
jQuery('.menu-primary-container').mobileMenu({
    defaultText: 'Menu',
    className: 'menu-primary-responsive',
    containerClass: 'menu-primary-responsive-container',
    subMenuDash: '&ndash;'
});
});
			
jQuery(function () {
    jQuery('ul.menu-secondary').superfish({
        animation: {
            opacity: 'show'
        },
        autoArrows: true,
        dropShadows: false,
        speed: 200,
        delay: 800
    });
});

jQuery(document).ready(function() {
jQuery('.menu-secondary-container').mobileMenu({
    defaultText: 'Navigation',
    className: 'menu-secondary-responsive',
    containerClass: 'menu-secondary-responsive-container',
    subMenuDash: '&ndash;'
});
});

jQuery(document).ready(function() {
	jQuery('.fp-slides').cycle({
		fx: 'scrollHorz',
		timeout: 4000,
		delay: 0,
		speed: 400,
		next: '.fp-next',
		prev: '.fp-prev',
		pager: '.fp-pager',
		continuous: 0,
		sync: 1,
		pause: 1,
		pauseOnPagerHover: 1,
		cleartype: true,
		cleartypeNoBg: true
	});
 });

/* ]]> */

</script>
<script type='text/javascript'>
//<![CDATA[

function showrecentcomments(json){for(var i=0;i<a_rc;i++){var b_rc=json.feed.entry[i];var c_rc;if(i==json.feed.entry.length)break;for(var k=0;k<b_rc.link.length;k++){if(b_rc.link[k].rel=='alternate'){c_rc=b_rc.link[k].href;break;}}c_rc=c_rc.replace("#","#comment-");var d_rc=c_rc.split("#");d_rc=d_rc[0];var e_rc=d_rc.split("/");e_rc=e_rc[5];e_rc=e_rc.split(".html");e_rc=e_rc[0];var f_rc=e_rc.replace(/-/g," ");f_rc=f_rc.link(d_rc);var g_rc=b_rc.published.$t;var h_rc=g_rc.substring(0,4);var i_rc=g_rc.substring(5,7);var j_rc=g_rc.substring(8,10);var k_rc=new Array();k_rc[1]="Jan";k_rc[2]="Feb";k_rc[3]="Mar";k_rc[4]="Apr";k_rc[5]="May";k_rc[6]="Jun";k_rc[7]="Jul";k_rc[8]="Aug";k_rc[9]="Sep";k_rc[10]="Oct";k_rc[11]="Nov";k_rc[12]="Dec";if("content" in b_rc){var l_rc=b_rc.content.$t;}else if("summary" in b_rc){var l_rc=b_rc.summary.$t;}else var l_rc="";var re=/<\S[^>]*>/g;l_rc=l_rc.replace(re,"");if(m_rc==true)document.write('On '+k_rc[parseInt(i_rc,10)]+' '+j_rc+' ');document.write('<a href="'+c_rc+'">'+b_rc.author[0].name.$t+'</a> commented');if(n_rc==true)document.write(' on '+f_rc);document.write(': ');if(l_rc.length<o_rc){document.write('<i>&#8220;');document.write(l_rc);document.write('&#8221;</i><br/><br/>');}else{document.write('<i>&#8220;');l_rc=l_rc.substring(0,o_rc);var p_rc=l_rc.lastIndexOf(" ");l_rc=l_rc.substring(0,p_rc);document.write(l_rc+'&hellip;&#8221;</i>');document.write('<br/><br/>');}}}

function rp(json){document.write('<ul>');for(var i=0;i<numposts;i++){document.write('<li>');var entry=json.feed.entry[i];var posttitle=entry.title.$t;var posturl;if(i==json.feed.entry.length)break;for(var k=0;k<entry.link.length;k++){if(entry.link[k].rel=='alternate'){posturl=entry.link[k].href;break}}posttitle=posttitle.link(posturl);var readmorelink="(more)";readmorelink=readmorelink.link(posturl);var postdate=entry.published.$t;var cdyear=postdate.substring(0,4);var cdmonth=postdate.substring(5,7);var cdday=postdate.substring(8,10);var monthnames=new Array();monthnames[1]="Jan";monthnames[2]="Feb";monthnames[3]="Mar";monthnames[4]="Apr";monthnames[5]="May";monthnames[6]="Jun";monthnames[7]="Jul";monthnames[8]="Aug";monthnames[9]="Sep";monthnames[10]="Oct";monthnames[11]="Nov";monthnames[12]="Dec";if("content"in entry){var postcontent=entry.content.$t}else if("summary"in entry){var postcontent=entry.summary.$t}else var postcontent="";var re=/<\S[^>]*>/g;postcontent=postcontent.replace(re,"");document.write(posttitle);if(showpostdate==true)document.write(' - '+monthnames[parseInt(cdmonth,10)]+' '+cdday);if(showpostsummary==true){if(postcontent.length<numchars){document.write(postcontent)}else{postcontent=postcontent.substring(0,numchars);var quoteEnd=postcontent.lastIndexOf(" ");postcontent=postcontent.substring(0,quoteEnd);document.write(postcontent+'...'+readmorelink)}}document.write('</li>')}document.write('</ul>')}

//]]>
</script>
<script type='text/javascript'>
summary_noimg = 550;
summary_img = 450;
img_thumb_height = 150;
img_thumb_width = 200; 
</script>
<script type='text/javascript'>
//<![CDATA[

function removeHtmlTag(strx,chop){ 
	if(strx.indexOf("<")!=-1)
	{
		var s = strx.split("<"); 
		for(var i=0;i<s.length;i++){ 
			if(s[i].indexOf(">")!=-1){ 
				s[i] = s[i].substring(s[i].indexOf(">")+1,s[i].length); 
			} 
		} 
		strx =  s.join(""); 
	}
	chop = (chop < strx.length-1) ? chop : strx.length-2; 
	while(strx.charAt(chop-1)!=' ' && strx.indexOf(' ',chop)!=-1) chop++; 
	strx = strx.substring(0,chop-1); 
	return strx+'...'; 
}

function createSummaryAndThumb(pID){
	var div = document.getElementById(pID);
	var imgtag = "";
	var img = div.getElementsByTagName("img");
	var summ = summary_noimg;
	if(img.length>=1) {	
		imgtag = '<img src="'+img[0].src.replace(/\/s(320|400|640|1600)/, "\/w200") +'" class="pbtthumbimg"/>';
		summ = summary_img;
	}
	
	var summary = imgtag + '<div>' + removeHtmlTag(div.innerHTML,summ) + '</div>';
	div.innerHTML = summary;
}

//]]>
</script>
<style type='text/css'>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</style>
<style type='text/css'>
.post-body img {padding:0px;background:transparent;border:none;}
</style>
<!--[if lte IE 8]> <style type='text/css'> #search{background-position:99% 20%;height:16px;} .fp-slider {height:300px;} .fp-nav {display:none;} </style> <![endif]-->
<script src='http://apis.google.com/js/plusone.js' type='text/javascript'>
{lang: 'en-US'}
</script>
<link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=2830313173919008722&amp;zx=6fca3b2d-c3cd-4b2c-8359-475f13efbcc0' media='none' onload='if(media!=&#39;all&#39;)media=&#39;all&#39;' rel='stylesheet'/><noscript><link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=2830313173919008722&amp;zx=6fca3b2d-c3cd-4b2c-8359-475f13efbcc0' rel='stylesheet'/></noscript>
</head>
<body>
<div id='body-wrapper'><div id='outer-wrapper'><div id='wrap2'>
<div id='headertop-wrapper'>
<div class='headertoppbt section' id='headertoppbt'><div class='widget HTML' data-version='1' id='HTML4'>
<div class='widget-content'>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- New Ad Campaign -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-6229255782347754"
     data-ad-slot="6680896733"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div class='clear'></div>
<span class='widget-item-control'>
<span class='item-control blog-admin'>
<a class='quickedit' href='//www.blogger.com/rearrange?blogID=2830313173919008722&widgetType=HTML&widgetId=HTML4&action=editWidget&sectionId=headertoppbt' onclick='return _WidgetManager._PopupConfig(document.getElementById("HTML4"));' target='configHTML4' title='Edit'>
<img alt='' height='18' src='https://resources.blogblog.com/img/icon18_wrench_allbkg.png' width='18'/>
</a>
</span>
</span>
<div class='clear'></div>
</div></div>
</div>
<div id='header-wrapper'>
<div class='header section' id='header'><div class='widget Header' data-version='1' id='Header1'>
<div id='header-inner'>
<a href='http://www.punchdrunkcritics.com/' style='display: block'>
<img alt='Punch Drunk Critics' height='80px; ' id='Header1_headerimg' src='http://1.bp.blogspot.com/-ru1zNt-QH3U/VIpGBExcYzI/AAAAAAAAAck/3pev2v6sNOo/s1600/PDC%2BHEADER%2BIMAGE.png' style='display: block;padding-left:0px;padding-top:0px;' width='300px; '/>
</a>
</div>
</div></div>
<div style='clear:both;'></div>
</div>
<div style='clear:both;'></div>
<div class='span-24'>
<div class='menu-secondary-container'>
<ul class='menus menu-secondary'>
<li><a href='http://www.punchdrunkcritics.com/'>Home</a></li>
<li><a href='http://www.punchdrunkcritics.com/search/label/reviews'>Reviews</a>
<ul class='children'>
<li><a href='http://www.punchdrunkcritics.com/search/label/travis'>Travis Hopson</a></li>
<li><a href='http://www.punchdrunkcritics.com/search/label/John'>John Nolan</a></li>
<li><a href='http://www.punchdrunkcritics.com/search/label/rockyh'>Rocky Hadadi</a></li>
<li><a href='http://www.punchdrunkcritics.com/search/label/Julian'>Julian Lytle</a></li>
<li><a href='http://www.punchdrunkcritics.com/search/label/Mae'>Mae Abdulbaki</a></li>
<li><a href='http://www.punchdrunkcritics.com/search/label/JohnA'>John Armstrong</a></li>
</ul>
</li>
<li><a href='http://www.punchdrunkcritics.com/search/label/news'>News</a>
<ul class='children'>
<li><a href='http://www.punchdrunkcritics.com/search/label/news'>News</a></li>
<li><a href='http://www.punchdrunkcritics.com/search/label/trailer'>Trailers</a></li>
<li><a href='http://www.punchdrunkcritics.com/search/label/images'>Images</a></li>
<li><a href='http://www.punchdrunkcritics.com/search/label/rumor'>Rumors</a></li>
<li><a href='http://www.punchdrunkcritics.com/search/label/boxoffice'>Box Office</a></li>
</ul>
</li>
<li><a href='http://www.punchdrunkcritics.com/search/label/features'>Features</a></li>
<li><a href='http://www.punchdrunkcritics.com/search/label/interview'>Interviews</a></li>
<li><a href='http://www.punchdrunkcritics.com/search/label/TV'>TV</a></li>
<li><a href='http://www.punchdrunkcritics.com/search/label/dvd'>DVD</a>
<ul class='children'>
<li><a href='http://www.punchdrunkcritics.com/search/label/dvdreleases'>DVD Releases</a></li>
<li><a href='http://www.punchdrunkcritics.com/search/label/VOD'>Video on Demand</a></li>
<li><a href='http://www.punchdrunkcritics.com/search/label/stream'>Streaming</a></li>
</ul>
</li>
<li><a href='http://www.punchdrunkcritics.com/search/label/contests'>Contests</a>
<ul class='children'>
<li><a href='http://www.punchdrunkcritics.com/search/label/screenings'>Screenings</a></li>
<li><a href='http://www.punchdrunkcritics.com/search/label/giveaways'>Giveaways</a></li>
</ul>
</li>
<li><a href='http://www.punchdrunkcritics.com/search/label/podcasts'>Podcasts</a>
<ul class='children'>
<li><a href='http://www.blogtalkradio.com/punchdrunkcritics'>The Punch Drunk Podcast</a></li>
<li><a href='http://www.blogtalkradio.com/cinemaroyale'>Cinema Royale</a></li>
<li><a href='http://www.blogtalkradio.com/cinemaconqueso'>Cinema Con Queso</a></li>
</ul>
</li>
<li><a href='http://astore.amazon.com/pundrucri-20'>Shop</a></li>
</ul>
</div>
</div>
<div style='clear:both;'></div>
<div id='content-wrapper'>
<div id='crosscol-wrapper' style='text-align:center'>
<div class='crosscol no-items section' id='crosscol'></div>
</div>
<div id='main-wrapper'>
<!-- Featured Content Slider Started -->
<!-- Featured Content Slider End -->
<div class='main section' id='main'><div class='widget Blog' data-version='1' id='Blog1'>
<div class='blog-posts hfeed'>
<!--Can't find substitution for tag [defaultAdStart]-->

          <div class="date-outer">
        
<h2 class='date-header'><span>4/12/2018</span></h2>

          <div class="date-posts">
        
<div class='post-outer'>
<div class='wrapfullpost'>
<div class='post hentry' itemprop='blogPost' itemscope='itemscope' itemtype='http://schema.org/BlogPosting'>
<meta content='https://1.bp.blogspot.com/-yMA4IOgiIEs/Ws7rRc--MVI/AAAAAAACM0Q/HE1tHRh_CAYEaz0HUZt4hta3zeulpmdmwCLcBGAs/s400/Rogue-One-Star-Wars-Story-Chirrut-Imwe-Blind.jpg' itemprop='image'/>
<a name='6688079757121638420'></a>
<h3 class='post-title entry-title' itemprop='name'>
<a href='http://www.punchdrunkcritics.com/2018/04/rogue-one-star-donnie-yen-cast-in.html'>'Rogue One' Star Donnie Yen Cast In Disney's Live-Action 'Mulan' </a>
</h3>
<div class='post-header-line-1'></div>
<div class='postmeta-primary'>
<span class='meta_author post-author vcard'>By&nbsp;<span class='fn' itemprop='author' itemscope='itemscope' itemtype='http://schema.org/Person'><meta content='https://plus.google.com/113669540013483424419' itemprop='url'/><a class='g-profile' href='https://plus.google.com/113669540013483424419' rel='author' title='author profile'><span itemprop='name'>Travis Hopson</span></a></span></span><meta content='http://www.punchdrunkcritics.com/2018/04/rogue-one-star-donnie-yen-cast-in.html' itemprop='url'/><span class='meta_date'><a class='timestamp-link' href='http://www.punchdrunkcritics.com/2018/04/rogue-one-star-donnie-yen-cast-in.html' rel='bookmark' title='permanent link'><span class='published updated' itemprop='datePublished' title='2018-04-12T01:15:00-04:00'>4/12/2018</span></a></span><span class='meta_comments'><a class='dsq-comment-count comment-link commentslink' href='http://www.punchdrunkcritics.com/2018/04/rogue-one-star-donnie-yen-cast-in.html#disqus_thread' title='View Comments on &#39;Rogue One&#39; Star Donnie Yen Cast In Disney&#39;s Live-Action &#39;Mulan&#39; '>View Comments</a></span>
</div>
<div class='post-body entry-content' id='post-body-6688079757121638420' itemprop='articleBody'>
<div class="separator" style="clear: both; text-align: center;">
<a href="https://1.bp.blogspot.com/-yMA4IOgiIEs/Ws7rRc--MVI/AAAAAAACM0Q/HE1tHRh_CAYEaz0HUZt4hta3zeulpmdmwCLcBGAs/s1600/Rogue-One-Star-Wars-Story-Chirrut-Imwe-Blind.jpg" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" data-original-height="316" data-original-width="600" height="210" src="https://1.bp.blogspot.com/-yMA4IOgiIEs/Ws7rRc--MVI/AAAAAAACM0Q/HE1tHRh_CAYEaz0HUZt4hta3zeulpmdmwCLcBGAs/s400/Rogue-One-Star-Wars-Story-Chirrut-Imwe-Blind.jpg" width="400" /></a></div>
<br />
This seems like such a no-brainer it's a wonder to have taken so long. The incredible Donnie Yen has joined the cast of Disney's live-action <strong>Mulan</strong> in one of the story's most crucial roles.<br />
<br />
The Hong Kong superstar and<strong> Rogue One </strong>actor will play Commander Tung, a mentor and teacher to Mulan, a young girl who dressed as a man so she could fight to defender people. Liu Yifei is set to play Mulan, with <strong>Whale Rider</strong> director Niki Caro at the helm. <br />
<br />
Disney seems to be doing this one right, hiring a female director and actual Chinese actors for the major roles. Plus you just can't go wrong casting<strong> Ip Man</strong> himself in anything.&nbsp; <strong>Mulan</strong> is scheduled to open on March 27th 2020. [<a href="http://deadline.com/2018/04/donnie-yen-mulan-disney-live-action-film-1202362542/">Deadline</a>]
<div style='clear:both;'></div>
<div class='post-share-buttons'>
<a class='goog-inline-block share-button sb-email' href='&target=email' target='_blank' title='Email This'><span class='share-button-link-text'>Email This</span></a><a class='goog-inline-block share-button sb-blog' href='&target=blog' onclick='window.open(this.href, "_blank", "height=270,width=475"); return false;' target='_blank' title='BlogThis!'><span class='share-button-link-text'>BlogThis!</span></a><a class='goog-inline-block share-button sb-twitter' href='&target=twitter' target='_blank' title='Share to Twitter'><span class='share-button-link-text'>Share to Twitter</span></a><a class='goog-inline-block share-button sb-facebook' href='&target=facebook' onclick='window.open(this.href, "_blank", "height=430,width=640"); return false;' target='_blank' title='Share to Facebook'><span class='share-button-link-text'>Share to Facebook</span></a><div class='goog-inline-block dummy-container'><g:plusone source='blogger:blog:plusone' href='http://www.punchdrunkcritics.com/2018/04/rogue-one-star-donnie-yen-cast-in.html' size='medium' width='300' annotation='inline'/></div>
</div>
<span class='reaction-buttons'>
</span>
<div style='clear: both;'></div>
</div>
<div class='post-footer'>
<div class='post-footer-line post-footer-line-'></div>
<div class='post-footer-line post-footer-line-2'></div>
<div class='post-footer-line post-footer-line-3'>
</div></div>
</div>
</div>
<div class='blog-pager' id='blog-pager'>
<span id='blog-pager-older-link'>
<a class='blog-pager-older-link' href='http://www.punchdrunkcritics.com/2018/04/john-krasinski-goes-from-quiet-place-to.html' id='Blog1_blog-pager-older-link' title='Older Post'>Older Post</a>
</span>
<a class='home-link' href='http://www.punchdrunkcritics.com/'>Home</a>
</div>
<div class='clear'></div>
<div class='comments' id='comments'>
<a name='comments'></a>
<div id='backlinks-container'>
<div id='Blog1_backlinks-container'>
</div>
</div>
</div>
</div>
<!--Can't find substitution for tag [defaultAdEnd]-->
<!--Can't find substitution for tag [adStart]-->

        </div></div>
      
<!--Can't find substitution for tag [adEnd]-->
</div>
<script type="text/javascript">window.___gcfg = {'lang': 'en'};</script>
</div></div>
</div>
<div id='rsidebar-wrapper'>
<div class='widget-container2'>
<div class='social-profiles-widget'>
<h3 class='widgettitle'>Social Profiles</h3>
<a href='http://twitter.com/punchycritic' target='_blank'><img alt='Twitter' src='http://4.bp.blogspot.com/-ikn8X-zIdho/UUpCnYJMkCI/AAAAAAAABg8/vqAaTThHAXo/s000/twitter.png' title='Twitter'/></a>
<a href='http://facebook.com/pages/Punch-Drunk-Critics/127274307080' target='_blank'><img alt='Facebook' src='http://1.bp.blogspot.com/-EVOhwWtd-jo/UUpCnnWFuPI/AAAAAAAABhE/31CM96Nx37Q/s000/facebook.png' title='Facebook'/></a>
<a href='https://plus.google.com/113669540013483424419' rel='publisher' target='_blank'><img alt='Google Plus' src='http://1.bp.blogspot.com/-dlgKO3X2WXA/UUpCn8t8hZI/AAAAAAAABhM/lw0OHkGUEQA/s000/gplus.png' title='Google Plus'/></a>
<a href='http://www.punchdrunkcritics.com/feeds/posts/default?alt=rss' target='_blank'><img alt='RSS Feed' src='http://3.bp.blogspot.com/-DkJ1tegsiCo/UUpCpDEI0lI/AAAAAAAABhg/rq8m2UBfaKk/s000/rss.png' title='RSS Feed'/></a>
<a href='mailto:punchdrunkcritics@gmail.com;punchdrunkcritics@yahoo.com' target='_blank'><img alt='Email' src='http://3.bp.blogspot.com/-u9vHeQZ7fqo/UUpCpilkfgI/AAAAAAAABho/M1AXYpwIAo0/s000/email.png' title='Email'/></a>
</div>
</div>
<div style='clear:both;'></div>
<div class='widget-container2'>
<div id='search' title='Type and hit enter'>
<form action='http://www.punchdrunkcritics.com/search/' id='searchform' method='get'>
<input id='s' name='q' onblur='if (this.value == "") {this.value = "Search";}' onfocus='if (this.value == "Search") {this.value = "";}' type='text' value='Search'/>
</form>
</div>
</div>
<div style='clear:both;'></div>
<div class='widget-container2'>
<div class='tabviewsection'>
<script type='text/javascript'>
            jQuery(document).ready(function($){
                $(".tabs-widget-content-widget-themater_tabs-1432447472-id").hide();
            	$("ul.tabs-widget-widget-themater_tabs-1432447472-id li:first a").addClass("tabs-widget-current").show();
            	$(".tabs-widget-content-widget-themater_tabs-1432447472-id:first").show();
       
            	$("ul.tabs-widget-widget-themater_tabs-1432447472-id li a").click(function() {
            		$("ul.tabs-widget-widget-themater_tabs-1432447472-id li a").removeClass("tabs-widget-current a"); 
            		$(this).addClass("tabs-widget-current"); 
            		$(".tabs-widget-content-widget-themater_tabs-1432447472-id").hide(); 
            	    var activeTab = $(this).attr("href"); 
            	    $(activeTab).fadeIn();
            		return false;
            	});
            });
        </script>
<ul class='tabs-widget tabs-widget-widget-themater_tabs-1432447472-id'>
<li><a href='#widget-themater_tabs-1432447472-id1'>Popular</a></li>
<li><a href='#widget-themater_tabs-1432447472-id2'>Tags</a></li>
<li><a href='#widget-themater_tabs-1432447472-id3'>Blog Archives</a></li>
</ul>
<div class='tabs-widget-content tabs-widget-content-widget-themater_tabs-1432447472-id' id='widget-themater_tabs-1432447472-id1'>
<div class='sidebar section' id='sidebartab1'><div class='widget HTML' data-version='1' id='HTML5'>
<div class='widget-content'>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:inline-block;width:250px;height:250px"
     data-ad-client="ca-pub-6229255782347754"
     data-ad-slot="6318660290"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div class='clear'></div>
<span class='widget-item-control'>
<span class='item-control blog-admin'>
<a class='quickedit' href='//www.blogger.com/rearrange?blogID=2830313173919008722&widgetType=HTML&widgetId=HTML5&action=editWidget&sectionId=sidebartab1' onclick='return _WidgetManager._PopupConfig(document.getElementById("HTML5"));' target='configHTML5' title='Edit'>
<img alt='' height='18' src='https://resources.blogblog.com/img/icon18_wrench_allbkg.png' width='18'/>
</a>
</span>
</span>
<div class='clear'></div>
</div><div class='widget Image' data-version='1' id='Image2'>
<h2>DC Area Film Critics Assoc.</h2>
<div class='widget-content'>
<a href='http://www.dcfilmcritics.com'>
<img alt='DC Area Film Critics Assoc.' height='90' id='Image2_img' src='http://1.bp.blogspot.com/-XyFmyPQBX7Y/Ud1osRYYpXI/AAAAAAAAC1U/nyvQKu6cGW4/s281/wafcalogo_full125.jpg' width='275'/>
</a>
<br/>
</div>
<div class='clear'></div>
<span class='widget-item-control'>
<span class='item-control blog-admin'>
<a class='quickedit' href='//www.blogger.com/rearrange?blogID=2830313173919008722&widgetType=Image&widgetId=Image2&action=editWidget&sectionId=sidebartab1' onclick='return _WidgetManager._PopupConfig(document.getElementById("Image2"));' target='configImage2' title='Edit'>
<img alt='' height='18' src='https://resources.blogblog.com/img/icon18_wrench_allbkg.png' width='18'/>
</a>
</span>
</span>
<div class='clear'></div>
</div><div class='widget PopularPosts' data-version='1' id='PopularPosts1'>
<div class='widget-content popular-posts'>
<ul>
<li>
<div class='item-thumbnail-only'>
<div class='item-thumbnail'>
<a href='http://www.punchdrunkcritics.com/2018/04/hirokazu-koreeda-is-making-film-with.html' target='_blank'>
<img alt='' border='0' height='72' src='https://2.bp.blogspot.com/-MrtjckgFEeE/WsulbXKnLJI/AAAAAAACMsQ/e0iHcfe7grw6butCnfjUDRTkUAnCwbidQCLcBGAs/s72-c/pdc_juliettebinoche.jpg' width='72'/>
</a>
</div>
<div class='item-title'><a href='http://www.punchdrunkcritics.com/2018/04/hirokazu-koreeda-is-making-film-with.html'>Hirokazu Koreeda Is Making A Film With Juliette Binoche, Catherine Deneuve, & Ethan Hawke</a></div>
</div>
<div style='clear: both;'></div>
</li>
<li>
<div class='item-thumbnail-only'>
<div class='item-thumbnail'>
<a href='http://www.punchdrunkcritics.com/2018/04/review-john-krasinskis-quiet-place-will.html' target='_blank'>
<img alt='' border='0' height='72' src='https://4.bp.blogspot.com/-wY0z9y4YceE/WsafGK8uAsI/AAAAAAACMms/lEyZ8eJL51YmoVh2BXz4Qw5qxbPPnaMXACLcBGAs/s72-c/pdc_aquietplace3.jpg' width='72'/>
</a>
</div>
<div class='item-title'><a href='http://www.punchdrunkcritics.com/2018/04/review-john-krasinskis-quiet-place-will.html'>Review: John Krasinski's 'A Quiet Place' Will Leave You Silent With Fear</a></div>
</div>
<div style='clear: both;'></div>
</li>
<li>
<div class='item-thumbnail-only'>
<div class='item-thumbnail'>
<a href='http://www.punchdrunkcritics.com/2018/04/dc-readers-win-passes-to-free-screening_9.html' target='_blank'>
<img alt='' border='0' height='72' src='https://4.bp.blogspot.com/-HJODIJtmOC0/Wsud3CSt6iI/AAAAAAACMrw/ye7lY1358D0hLlkHmgwhNHRWb-RQtqaTgCLcBGAs/s72-c/pdc_supertroopers2poster.jpg' width='72'/>
</a>
</div>
<div class='item-title'><a href='http://www.punchdrunkcritics.com/2018/04/dc-readers-win-passes-to-free-screening_9.html'>DC Readers: Win Passes To A Free Screening Of 'Super Troopers 2' </a></div>
</div>
<div style='clear: both;'></div>
</li>
<li>
<div class='item-thumbnail-only'>
<div class='item-thumbnail'>
<a href='http://www.punchdrunkcritics.com/2018/04/review-chappaquiddick-ted-kennedys.html' target='_blank'>
<img alt='' border='0' height='72' src='https://3.bp.blogspot.com/-XCVXmaP0fdI/WsdJmAze55I/AAAAAAACMnw/uLM1qk1KJG4vJF_WAoljDreLMwgq1Q5pQCEwYBhgL/s72-c/chappaquiddick-trailer-fb.jpg' width='72'/>
</a>
</div>
<div class='item-title'><a href='http://www.punchdrunkcritics.com/2018/04/review-chappaquiddick-ted-kennedys.html'>Review: 'Chappaquiddick', Ted Kennedy's Legacy Gets Battered And Bruised</a></div>
</div>
<div style='clear: both;'></div>
</li>
<li>
<div class='item-thumbnail-only'>
<div class='item-thumbnail'>
<a href='http://www.punchdrunkcritics.com/2018/04/deadpool-2-villain-possibly-cut-while-x.html' target='_blank'>
<img alt='' border='0' height='72' src='https://3.bp.blogspot.com/-5DdvKcZXLtQ/Wsi8JaUgM0I/AAAAAAACMp4/F_DmoHyIBPoPRkQOZon5FubMXb4R_FRXQCLcBGAs/s72-c/pdc_deadpool2postercrop.jpg' width='72'/>
</a>
</div>
<div class='item-title'><a href='http://www.punchdrunkcritics.com/2018/04/deadpool-2-villain-possibly-cut-while-x.html'>*Update* 'Deadpool 2' Villain Not Cut From Movie, Jessica Chastain's 'Dark Phoenix' Role May Be Revealed</a></div>
</div>
<div style='clear: both;'></div>
</li>
</ul>
<div class='clear'></div>
<span class='widget-item-control'>
<span class='item-control blog-admin'>
<a class='quickedit' href='//www.blogger.com/rearrange?blogID=2830313173919008722&widgetType=PopularPosts&widgetId=PopularPosts1&action=editWidget&sectionId=sidebartab1' onclick='return _WidgetManager._PopupConfig(document.getElementById("PopularPosts1"));' target='configPopularPosts1' title='Edit'>
<img alt='' height='18' src='https://resources.blogblog.com/img/icon18_wrench_allbkg.png' width='18'/>
</a>
</span>
</span>
<div class='clear'></div>
</div>
</div><div class='widget Text' data-version='1' id='Text3'>
<h2 class='title'>Takin' Over Facebook!</h2>
<div class='widget-content'>
<span style="font-family:Georgia, serif;"><iframe src="//www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2Fpages%2FPunch-Drunk-Critics%2F127274307080&amp;width=250&amp;height=258&amp;colorscheme=light&amp;show_faces=true&amp;header=false&amp;stream=false&amp;show_border=true&amp;appId=124104092661" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:250px; height:258px;" allowtransparency="true"></iframe></span>
</div>
<div class='clear'></div>
<span class='widget-item-control'>
<span class='item-control blog-admin'>
<a class='quickedit' href='//www.blogger.com/rearrange?blogID=2830313173919008722&widgetType=Text&widgetId=Text3&action=editWidget&sectionId=sidebartab1' onclick='return _WidgetManager._PopupConfig(document.getElementById("Text3"));' target='configText3' title='Edit'>
<img alt='' height='18' src='https://resources.blogblog.com/img/icon18_wrench_allbkg.png' width='18'/>
</a>
</span>
</span>
<div class='clear'></div>
</div><div class='widget HTML' data-version='1' id='HTML2'>
<h2 class='title'>Entertainment Earth</h2>
<div class='widget-content'>
<a href="https://www.entertainmentearth.com/prodinfo.asp?number=FU14012EE&utm_source=ee-affiliates&utm_medium=web&250x250_aff_ww_pop&utm_campaign=wonderwoman&id=PU-103092114"><img src="https://www.entertainmentearth.com/images/affiliates/banners/250x250_aff_ww_pop.gif" width="250" height="250" alt="Entertainment Earth" border="0" /></a>
</div>
<div class='clear'></div>
<span class='widget-item-control'>
<span class='item-control blog-admin'>
<a class='quickedit' href='//www.blogger.com/rearrange?blogID=2830313173919008722&widgetType=HTML&widgetId=HTML2&action=editWidget&sectionId=sidebartab1' onclick='return _WidgetManager._PopupConfig(document.getElementById("HTML2"));' target='configHTML2' title='Edit'>
<img alt='' height='18' src='https://resources.blogblog.com/img/icon18_wrench_allbkg.png' width='18'/>
</a>
</span>
</span>
<div class='clear'></div>
</div><div class='widget HTML' data-version='1' id='HTML3'>
<div class='widget-content'>
<a href="http://www.dpbolvw.net/click-7774006-13269095" target="_top">
<img src="http://www.lduhtrp.net/image-7774006-13269095" width="300" height="250" alt="Free Exclusive Poster with purchase of tickets for 'Avengers: Infinity War'" border="0"/></a>
</div>
<div class='clear'></div>
<span class='widget-item-control'>
<span class='item-control blog-admin'>
<a class='quickedit' href='//www.blogger.com/rearrange?blogID=2830313173919008722&widgetType=HTML&widgetId=HTML3&action=editWidget&sectionId=sidebartab1' onclick='return _WidgetManager._PopupConfig(document.getElementById("HTML3"));' target='configHTML3' title='Edit'>
<img alt='' height='18' src='https://resources.blogblog.com/img/icon18_wrench_allbkg.png' width='18'/>
</a>
</span>
</span>
<div class='clear'></div>
</div><div class='widget HTML' data-version='1' id='HTML1'>
<script type='text/javascript'>
                var disqus_shortname = 'punchdrunkcritics';
                var disqus_blogger_current_url = "http://www.punchdrunkcritics.com/2018/04/rogue-one-star-donnie-yen-cast-in.html";
                if (!disqus_blogger_current_url.length) {
                    disqus_blogger_current_url = "http://www.punchdrunkcritics.com/2018/04/rogue-one-star-donnie-yen-cast-in.html";
                }
                var disqus_blogger_homepage_url = "http://www.punchdrunkcritics.com/";
                var disqus_blogger_canonical_homepage_url = "http://www.punchdrunkcritics.com/";
            </script>
<style type='text/css'>
                    #comments {display:none;}
                </style>
<script type='text/javascript'>
                    (function() {
                        var bloggerjs = document.createElement('script');
                        bloggerjs.type = 'text/javascript';
                        bloggerjs.async = true;
                        bloggerjs.src = 'http://'+disqus_shortname+'.disqus.com/blogger_item.js';
                        (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(bloggerjs);
                    })();
                </script>
<style type='text/css'>
                    .post-comment-link { visibility: hidden; }
                </style>
<script type='text/javascript'>
                (function() {
                    var bloggerjs = document.createElement('script');
                    bloggerjs.type = 'text/javascript';
                    bloggerjs.async = true;
                    bloggerjs.src = 'http://'+disqus_shortname+'.disqus.com/blogger_index.js';
                    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(bloggerjs);
                })();
                </script>
</div><div class='widget HTML' data-version='1' id='HTML6'>
<h2 class='title'>Zergnet</h2>
<div class='widget-content'>
<div id="zergnet-widget-64211"></div>

<script language="javascript" type="text/javascript">
	(function() {
		var zergnet = document.createElement('script');
		zergnet.type = 'text/javascript'; zergnet.async = true;
		zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=64211';
		var znscr = document.getElementsByTagName('script')[0];
		znscr.parentNode.insertBefore(zergnet, znscr);
	})();
</script>
</div>
<div class='clear'></div>
<span class='widget-item-control'>
<span class='item-control blog-admin'>
<a class='quickedit' href='//www.blogger.com/rearrange?blogID=2830313173919008722&widgetType=HTML&widgetId=HTML6&action=editWidget&sectionId=sidebartab1' onclick='return _WidgetManager._PopupConfig(document.getElementById("HTML6"));' target='configHTML6' title='Edit'>
<img alt='' height='18' src='https://resources.blogblog.com/img/icon18_wrench_allbkg.png' width='18'/>
</a>
</span>
</span>
<div class='clear'></div>
</div><div class='widget HTML' data-version='1' id='HTML11'>
<h2 class='title'>The Screening Room</h2>
<div class='widget-content'>
<table border=0 style="background-color: #fff; padding: 5px;" cellspacing=0>
  <tr><td>
  <img src="http://groups.google.com/intl/en/images/logos/groups_logo_sm.gif" 
 height="30" width="140" alt="Google Groups" />
  </td></tr>
  <tr><td style="padding-left: 5px">
  <b>Subscribe to Punch Drunk Critics</b>
  </td></tr>
  <form action="http://groups.google.com/group/punch-drunk-critics/boxsubscribe">
  <input type="hidden" name="hl" value="en" />
  <tr><td style="padding-left: 5px;">
  Email: <input type="text" name="email" />
  <input type="submit" name="sub" value="Subscribe" />
  </td></tr>
</form>
<tr><td align=right>
  <a href="http://groups.google.com/group/punch-drunk-critics?hl=en">Visit this group</a>
</td></tr>
</table>
</div>
<div class='clear'></div>
<span class='widget-item-control'>
<span class='item-control blog-admin'>
<a class='quickedit' href='//www.blogger.com/rearrange?blogID=2830313173919008722&widgetType=HTML&widgetId=HTML11&action=editWidget&sectionId=sidebartab1' onclick='return _WidgetManager._PopupConfig(document.getElementById("HTML11"));' target='configHTML11' title='Edit'>
<img alt='' height='18' src='https://resources.blogblog.com/img/icon18_wrench_allbkg.png' width='18'/>
</a>
</span>
</span>
<div class='clear'></div>
</div><div class='widget Attribution' data-version='1' id='Attribution1'>
<div class='widget-content' style='text-align: center;'>
Powered by <a href='https://www.blogger.com' target='_blank'>Blogger</a>.
</div>
<div class='clear'></div>
<span class='widget-item-control'>
<span class='item-control blog-admin'>
<a class='quickedit' href='//www.blogger.com/rearrange?blogID=2830313173919008722&widgetType=Attribution&widgetId=Attribution1&action=editWidget&sectionId=sidebartab1' onclick='return _WidgetManager._PopupConfig(document.getElementById("Attribution1"));' target='configAttribution1' title='Edit'>
<img alt='' height='18' src='https://resources.blogblog.com/img/icon18_wrench_allbkg.png' width='18'/>
</a>
</span>
</span>
<div class='clear'></div>
</div><div class='widget Navbar' data-version='1' id='Navbar1'><script type="text/javascript">
    function setAttributeOnload(object, attribute, val) {
      if(window.addEventListener) {
        window.addEventListener('load',
          function(){ object[attribute] = val; }, false);
      } else {
        window.attachEvent('onload', function(){ object[attribute] = val; });
      }
    }
  </script>
<div id="navbar-iframe-container"></div>
<script type="text/javascript" src="https://apis.google.com/js/plusone.js"></script>
<script type="text/javascript">
      gapi.load("gapi.iframes:gapi.iframes.style.bubble", function() {
        if (gapi.iframes && gapi.iframes.getContext) {
          gapi.iframes.getContext().openChild({
              url: 'https://www.blogger.com/navbar.g?targetBlogID\x3d2830313173919008722\x26blogName\x3dPunch+Drunk+Critics\x26publishMode\x3dPUBLISH_MODE_HOSTED\x26navbarType\x3dLIGHT\x26layoutType\x3dLAYOUTS\x26searchRoot\x3dhttp://www.punchdrunkcritics.com/search\x26blogLocale\x3den\x26v\x3d2\x26homepageUrl\x3dhttp://www.punchdrunkcritics.com/\x26targetPostID\x3d6688079757121638420\x26blogPostOrPageUrl\x3dhttp://www.punchdrunkcritics.com/2018/04/rogue-one-star-donnie-yen-cast-in.html\x26vt\x3d-2527608120137166403',
              where: document.getElementById("navbar-iframe-container"),
              id: "navbar-iframe"
          });
        }
      });
    </script><script type="text/javascript">
(function() {
var script = document.createElement('script');
script.type = 'text/javascript';
script.src = '//pagead2.googlesyndication.com/pagead/js/google_top_exp.js';
var head = document.getElementsByTagName('head')[0];
if (head) {
head.appendChild(script);
}})();
</script>
</div></div>
</div>
<div class='tabs-widget-content tabs-widget-content-widget-themater_tabs-1432447472-id' id='widget-themater_tabs-1432447472-id2'>
<div class='sidebar section' id='sidebartab2'><div class='widget AdSense' data-version='1' id='AdSense2'>
<div class='widget-content'>
<script type="text/javascript">
    google_ad_client = "ca-pub-6229255782347754";
    google_ad_host = "ca-host-pub-1556223355139109";
    google_ad_host_channel = "L0001";
    google_ad_slot = "6318660290";
    google_ad_width = 250;
    google_ad_height = 250;
</script>
<!-- punchdrunkcritics_sidebartab2_AdSense2_250x250_as -->
<script type="text/javascript"
src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
<div class='clear'></div>
<span class='widget-item-control'>
<span class='item-control blog-admin'>
<a class='quickedit' href='//www.blogger.com/rearrange?blogID=2830313173919008722&widgetType=AdSense&widgetId=AdSense2&action=editWidget&sectionId=sidebartab2' onclick='return _WidgetManager._PopupConfig(document.getElementById("AdSense2"));' target='configAdSense2' title='Edit'>
<img alt='' height='18' src='https://resources.blogblog.com/img/icon18_wrench_allbkg.png' width='18'/>
</a>
</span>
</span>
<div class='clear'></div>
</div>
</div></div>
</div>
<div class='tabs-widget-content tabs-widget-content-widget-themater_tabs-1432447472-id' id='widget-themater_tabs-1432447472-id3'>
<div class='sidebar no-items section' id='sidebartab3'></div>
</div>
</div>
</div>
<div style='height:5px;clear:both;'></div>
<div class='sidebar no-items section' id='sidebarright'></div>
<p></p></div>
<!-- spacer for skins that want sidebar and main to be the same height-->
<div class='clear'>&#160;</div>
</div>
<!-- end content-wrapper -->
<div style='clear:both;'></div>
<div id='footer-widgets-container'>
<div class='clearfix' id='footer-widgets'>
<div class='footer-widget-box'>
<ul class='widget-container'>
<li>
<div class='footersec no-items section' id='footersec1'></div>
</li>
</ul>
</div>
<div class='footer-widget-box'>
<ul class='widget-container'>
<li>
<div class='footersec no-items section' id='footersec2'></div>
</li>
</ul>
</div>
<div class='footer-widget-box'>
<ul class='widget-container'>
<li>
<div class='footersec no-items section' id='footersec3'></div>
</li>
</ul>
</div>
<div class='footer-widget-box footer-widget-box-last'>
<ul class='widget-container'>
<li>
<div class='footersec no-items section' id='footersec4'></div>
</li>
</ul>
</div>
</div>
</div>
<div style='clear:both;'></div>
<div id='footer-container'>
<div id='footer'>
<div id='copyrights'>
Copyright &copy; <script type='text/javascript'>var creditsyear = new Date();document.write(creditsyear.getFullYear());</script>
<a href='http://www.punchdrunkcritics.com/'>Punch Drunk Critics</a> | Powered by <a href='http://www.blogger.com/'>Blogger</a>
</div>
<div id='credits'>
</div>
</div><!-- #footer -->
</div>
<div style='clear:both;'></div>
</div></div></div>
<!-- end outer-wrapper -->
<script asyncsrc='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script>
<!-- New Ad Campaign -->
<ins class='adsbygoogle' data-ad-client='ca-pub-6229255782347754' data-ad-slot='6680896733' style='display:inline-block;width:728px;height:90px'></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
<script src='https://apis.google.com/js/plusone.js' type='text/javascript'></script>

<script type="text/javascript" src="https://www.blogger.com/static/v1/widgets/2237632814-widgets.js"></script>
<script type='text/javascript'>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</script>
</body>
</html>